diff clipkit_repo/docs/setup.py @ 2:e9cf321ee7be draft

"planemo upload for repository https://github.com/jlsteenwyk/clipkit commit cbe1e8577ecb1a46709034a40dff36052e876e7a-dirty"
author padge
date Fri, 25 Mar 2022 17:33:41 +0000
parents 49b058e85902
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/clipkit_repo/docs/setup.py	Fri Mar 25 17:33:41 2022 +0000
@@ -0,0 +1,35 @@
+from os import path
+from setuptools import setup
+
+here = path.abspath(path.dirname(__file__))
+
+with open(path.join(here, "README.md"), encoding="utf-8") as f:
+    long_description = f.read()
+
+CLASSIFIERS = [
+    'Operating System :: OS Independent',
+    'Intended Audience :: Science/Research',
+    'Programming Language :: Python',
+    'Programming Language :: Python :: 3.6',
+    'Programming Language :: Python :: 3.7',
+    'Programming Language :: Python :: 3.8',
+    'Topic :: Scientific/Engineering',
+]
+
+REQUIRES = ["biopython==1.76", "numpy==1.18.2", "tqdm==4.45.0"]
+
+setup(
+    name="clipkit",
+    description="Alignment trimming software for phylogenetics.",
+    long_description=long_description,
+    long_description_content_type="text/markdown",
+    author="Jacob L. Steenwyk",
+    author_email="jlsteenwyk@gmail.com",
+    url="https://github.com/jlsteenwyk/clipkit",
+    packages=["clipkit"],
+    classifiers=CLASSIFIERS,
+    entry_points={"console_scripts": ["clipkit = clipkit.clipkit:main"]},
+    version="0.1.3",
+    include_package_data=True,
+    install_requires=REQUIRES,
+)