diff setup.py @ 14:628f82e72d72

Version as released on PyPI 0.1.0
author Vimalkumar Velayudhan <vimal@biotechcoder.com>
date Wed, 26 Aug 2015 16:37:10 +0100
parents 8e1efafa6277
children
line wrap: on
line diff
--- a/setup.py	Fri Aug 21 12:37:54 2015 +0100
+++ b/setup.py	Wed Aug 26 16:37:10 2015 +0100
@@ -14,9 +14,7 @@
 with open('HISTORY.rst') as history_file:
     history = history_file.read().replace('.. :changelog:', '')
 
-requirements = [
-    # TODO: put package requirements here
-]
+requirements = ['matplotlib==1.3.1', 'pysam==0.8.3']
 
 test_requirements = [
     # TODO: put package test requirements here
@@ -35,23 +33,27 @@
     ],
     package_dir={'riboplot':
                  'riboplot'},
-    include_package_data=True,
     install_requires=requirements,
-    license="BSD",
+    license="GPL",
     zip_safe=False,
     keywords='riboplot',
     classifiers=[
         'Development Status :: 2 - Pre-Alpha',
         'Intended Audience :: Developers',
-        'License :: OSI Approved :: BSD License',
+        'License :: OSI Approved :: GNU General Public License (GPL)',
         'Natural Language :: English',
         "Programming Language :: Python :: 2",
         'Programming Language :: Python :: 2.6',
         'Programming Language :: Python :: 2.7',
-        'Programming Language :: Python :: 3',
-        'Programming Language :: Python :: 3.3',
-        'Programming Language :: Python :: 3.4',
     ],
     test_suite='tests',
-    tests_require=test_requirements
-)
\ No newline at end of file
+    tests_require=test_requirements,
+    entry_points={
+        'console_scripts': [
+            'riboplot = riboplot.riboplot:run',
+            'ribocount = riboplot.ribocount:run']
+    },
+    package_data={'riboplot': ['data/*.html', 'data/css/*.gif', 'data/css/*.css',
+                               'data/js/*.js', 'data/js/*.map', 'scripts/*.sh']},
+    exclude_package_data={'tests': ['data/*.bam', 'data/*.bai', 'data/*.fna', 'data/*.fai']}
+)